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strictly followed in order to optimize these applications.
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a

The example and setup screens in this manual do
not reflect the actual application configurations. Be
sure to follow the correct setup procedures for your
application.

To prevent personal injury or equipment damage caused by
equipment malfunction, only adequately trained personnel
should modify any programmable machine.

b
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Chapter 1 Overview

Introduction
This document can apply to
various controllers or drives,
therefore the contents of the
dialog boxes can vary
according to your product.

This chapter describes the Trend Recorder, which monitors and graphs signal values
from controllers or drives and graphs data collection analysis (.dca) files. Data can
also be saved and exported for other applications, such as spreadsheets.

Data Collection
The Trend Recorder uses three methods to collect data: real-time, block-collected,
and reading .dca files.

Real-time
Real-time data is collected by the toolbox. Real-time mode is for low to medium
data collection rates. Signals can be trended from controllers and drives. When you
are real-time trending data from a controller, both internal signals in the device and
any external signal on a drive local area network (DLAN+) that the device is
attached to can be trended. All the signals are sampled at the same time by a task
running in the device. The sample set is then transmitted over the network to the
toolbox. You can set the sampling rate when you are configuring the trend. The
minimum interval between samples is 32 ms.
Real-time trending of internal data from a controller requires that the controller file
be loaded in the toolbox while the trend is being set up. DLAN+ signals can be
added to the trend without having the device file open in the toolbox; however, the
toolbox must have access to the System Database (SDB). Once the trend is set up,
data can be collected and displayed from a controller without the controller being
loaded in toolbox.

It is not necessary to have the
device file loaded while
replaying previously collected
data.

GEH-6408A Trend Recorder

Only internal signals can be trended from an AcDcEx. Signals are sampled one at a
time, sequentially. The sample interval between signals is an average 22 ms. The
interval between samples of the same signal is the number of signals multiplied by
the interval between samples. When real-time trending signals from a drive, you
must have the device file open in the toolbox while the trend is set up and also when
data is collected.
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Signal Sampling for
Real-time Drive Trending
Value
|22 ms|

|

3 * 22 ms

|

Time Axis

When trending from an Innovation Series drive, signal values are collected in a
group of four at a time, at an average rate of 20 ms per group. The sampling strategy
is similar to the AcDcEx drive; however, instead of getting only one signal value at a
time, the Trend Recorder reads up to four signals simultaneously. This greatly
improves the effective sampling rate over that of the AcDcEx drive.
Data is collected from the AcDcEx drive one signal value at a time. The average
sample interval between signals is about 50 ms.

Block Collection
Refer to the section, Block
Collected Trends.

Block collection is available in controllers and in the Innovation Series drive using
the Capture Buffer block and in other drives using the Circular List block. The data
is uploaded to the toolbox when the collection is completed. Block-collected mode is
for high speed trending. The only limit on collection rate is the execution rate of the
collector block.

It is not necessary to have the
configuration file loaded
while replaying previously
uploaded data.

Block-collected trending requires that the configuration file, which contains the
collector block, be loaded in the toolbox while the trend is set up and also when data
is uploaded from the block.

.dca Files
The .dca file is a common data storage format used by many applications. It is
primarily used to store data collected by the Data Historian product.
The Trend Recorder can read these files in two ways:
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•

Individually, where you specify the name(s) of the .dca files to load into the
Trend Recorder.

•

As part of a Data Historian Collected Trend, where you specify signals from a
particular Data Historian device and/or Data Historian collection. The Trend
Recorder determines the name(s) and location(s) of the necessary .dca files.

GEH-6408A Trend Recorder

Chapter 2 Trend Recorder Window

Introduction
This chapter provides instructions for using the toolbox to create a Trend Recorder.
It also describes toolbar and menu commands, as well as option settings.
For assistance, contact:
Industrial Systems, General Electric Company, Product Service Engineering
1501 Roanoke Blvd. Salem, VA 24513-6492 USA
Phone + 1 540 387 7595, Fax + 1 540 387 8606
(replace + with the international access code)

Creating a Trend Recorder
À To create a Trend Recorder
Or click

New

w

From the File menu, choose New. The New dialog box displays.

Click the Utilities tab.
Then click Trend
Recorder to highlight it,
and click OK.

GEH-6408A Trend Recorder
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Trend Recorder Window
To set options for recording
trends, refer to the section,
Trend Recorder Settings.

When the Trend Recorder Window is invoked, it displays as a separate window in
the toolbox. The window is divided into two views, which can be altered with the
adjustable split bar (see screen below). The Top Graph View of the Trend Recorder
Window displays the actual graph(s) and the lower Signal View displays the signals
that are monitored in the graph and their current values.

Tip ¬ Signals are selected in the lower Signal View when they are configured,
edited, and removed. Adjust the size of the Signal view by dragging the split bar,
shown in the screen below.

Signal Trace
Top Graph
View

Toolbox
Toolbar

Y-Axis
Labels
Adjustable
Split Bar
X-Axis
Labels
Lower
Signal View
Trend
Recorder
Toolbar
Cursor Position Values

Status Bar

Tip ¬ To view both the toolbox and the Trend Recorder window, choose Tile
Horizontal or Tile Vertical from the Window menu. Then, to invoke and work in the
Trend Recorder window, click anywhere in the Trend Recorder window or click
anywhere in the toolbox window.
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Modes of Operation
The Trend Recorder has several modes of operation. The modes are indicated in the
Status bar at the bottom of the Trend Recorder Window. These modes are:
Status bar displays Wait or
Record.

Record mode: captures data and displays it as a graph, which can then be saved to
disk. You can set Record to capture data continuously or only around a trigger event.

Status bar displays Replay.

Replay mode: allows you to review data collected in Record mode or uploaded from
a device-based block-collected trend. You can scan back and forth between multiple
recorded events to examine data in detail.

Status bar displays Upload.

Upload mode: captures data collected by a Capture Buffer block in a controller or in
an Innovation Series drive or by a Circular List block in other drives. You can set
Upload to run as a one-time event or leave the Trend Recorder in this mode. When
left in the Upload mode, the toolbox monitors the blocks and automatically uploads
data when a collection takes place.

Toolbar
The Trend Recorder toolbar contains the following menu commands:
Click. . .

To
Record displays and graphs of the current values of the selected signals. Data is also captured
and can be replayed or saved to disk.
Upload data collected by the data collector block in a controller or a drive device. If automatic
upload is selected, the Trend Recorder remains in upload mode until selected again.
Edit the data collector block.
Configure the Trend Recorder.
Move through events and display previously recorded data.
Move the current event back by one-third of the currently displayed width of the time axis.
Move the current event ahead by one-third of the currently displayed width of the time axis.
Move through events and display the next recorded data.
Add signal(s) to be trended.
Remove chosen signal(s) from the trend.
Configure the time (horizontal) axis parameters.
Automatically range the vertical axis based on the data currently displayed in the graph.
Zoom in and display the selected area of the graph between the replay cursors.
Zoom out and display the area of the graph to a maximum of three times the current screen.
Set the trend into X-Y plotting mode.

GEH-6408A Trend Recorder
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Edit Menu
The Edit menu allows you to change the configuration of the Trend Recorder as
follows:

Delete All Data removes all data collected by the Trend Recorder.
Delete This Event removes the recorded event that is currently displayed.
Add Signal adds a signal to the Trend Recorder.
Remove Signal removes the signal selected in the lower Signal View.
Get Signals retrieves configuration information from the SDB for DLAN+ signals
in real-time trends.
Hide Selected Signals conceals signals that are selected in the lower Signal
View.
Show Signals selects which signals are displayed and hidden.
Change Signal Device changes the drive that a drive signal is trended from.
Time Axis changes the range of the time axis.
Edit Selected Signal changes the range, color, line width, and style for a signal.
Show on Left/Right Axis of the trace displays the range of the selected signal.
Auto Range Vert. Axis causes the graph to set the range of all signals based on
the values of the signals that are currently displayed on the graph.
Configure invokes the Trend Recorder Configuration dialog box to set up the trend.
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Set Signal As Trigger specifies the selected signal as the trigger for real-time
triggered mode trends.
Move Signal Up/Down also
changes the position of the
signal in stacked view.

Move Signal Up moves the signal up one position in the Signal View.
Move Signal Down moves the signal down one position in the Signal View.
Set As X Axis marks the chosen signals to be the X-axis for X-Y plots.
Edit Block invokes a detached block diagram view in a block-collected trend.

View Menu
The View menu allows you to view areas of the Trend Recorder as follows:

Toolbar controls whether the Trend Recorder toolbar displays.
Status Bar controls whether the Trend Recorder status bar displays.
Stacked Traces controls whether the Trend Recorder displays each signal trace in
its own window (stacked mode) or in one signal graph view.
X-Y Plot Mode controls whether the X-axis of the Trend Recorder is based on the
value of one of the signals that has been collected (X-Y plot mode) or based on time
(normal mode).
Power Spectrum shows a spectral analysis of the trended data using a Fast Fourier
Transform.
Upload Data causes the data collected by the collector block of a block-collected
trend to be uploaded to the Trend Recorder.
Record starts and stops the Trend Recorder collecting data for a real-time trend.
Reload DCA File Data causes data to be re-read from a .dca file.
Previous Trend displays previously recorded data.
Rewind moves the current event back through the currently displayed trend by onethird of the currently displayed width of the time axis.

GEH-6408A Trend Recorder
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Forward moves the current event ahead by one-third of the currently displayed
width of the time axis.
Next Trend is used to move through events and display the next recorded data.
Only available when
replaying data.

Zoom In displays the area of the graph between replay cursors.

Only available when trending
from an AcDcEx.

Drive Terminal invokes the drive terminal window.

Zoom Out displays area of the graph to a maximum of three times current screen.

Event Note invokes the note editor. A note can be added to each trend event
(recording). Notes are displayed at the bottom of the page on printouts of trends.

Trend Recorder Settings
This document can apply to
various controllers or drives,
therefore the contents of the
dialog boxes can vary
according to your product.

À To choose specific settings for a trend
w

From the Options menu, choose Settings, and click the Trend Recorder
tab.

Click Horizontal Grid
Lines to display
horizontal grid lines
when in Replay mode.
Click Vertical Grid
Lines to display
vertical grid lines when
in Replay mode.

Select the font size
to be used in the
upper window of the
Trend Recorder.
Set the font and
size to be used in
the lower window of
the Trend Recorder.

Click Right Vertical
Axis to display vertical
axis on the right-hand
side of the Trend
Recorder.

Select the default
pen width
(measured in pixels)
used to draw the
signal traces.

Click here to
automatically configure
the Trend Recorder
with predefined
signals. (This feature
currently only works
with Innovation Series
drives and when
performing MarkVI I/O
board calibrations.)

This sets the
amount of memory
the toolbox reserves
for storing traces.
The default value of
2 MB allows 4
signals to be
captured at 32 ms
intervals for about
14 minutes before
the oldest data is
deleted.
Click Show
memory usage in
status bar to show
the amount of
reserved memory
that was used.

Click here to zoom in
and out of the Trend
Recorder, using the
mouse to drag-anddrop a rectangle on the
screen.
Click here for a Yes/No
confirmation prompt to
display before the
zoom takes place.

Note While waiting for a trigger condition, the Trend Recorder displays and graphs
the values of the signals. However, the values are not saved, and once they scroll off
the left-hand side of the graph screen, they cannot be viewed.
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Chapter 3 Types of Trends

Introduction
To set options for recording
trends, refer to the section,
Trend Recorder Settings.

This section provides instructions for using the toolbox to configure a Trend
Recorder. There are four types of trend configurations:
•

Real time

•

Block collected

•

Data Historian collected

•

.dca files

Real-time Trends
Setting up a real-time trend includes:

GEH-6408A Trend Recorder

•

Selecting the signals to be trended

•

Setting the scaling for both time and vertical axes

•

Setting the record mode and sampling rate
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Configuring the Trend
À To set up the real-time trend
w

From the Edit menu, choose Configure. The Trend Recorder
Configuration dialog box displays.

Real Time Trend Configuration

Continuous mode
collects data until
you stop recording.
If the trace buffers
fill up, the oldest
one-eighth of the
data in the buffer is
deleted.

Select the Real Time tab to
specify a live trend from the
drive or controller

Save Mode allows you to specify whether to save just the
setup for the trend or save the setup and all data that is
collected. Setup Only saves all the signals, their scaling,
the sample interval, axis ranges, and other setup data.

Triggered mode
captures data
based on a specific
event. In this mode,
the Trend Recorder
watches the value
of a designated
trigger Boolean
signal. You must
specify whether to
trigger based on
this signal being
True or on a value
transition. You can
also enter a time
interval to collect
data: Pre-Trigger
(before the trigger)
or Post-Trigger
Choose a signal to use as the trigger. Or choose the trigger
(after the trigger).
signal from the lower Signal View of the Trend Recorder window.
Then, from the Edit menu, choose Set Trigger Signal. An
asterisk displays beside the signal name, indicating that it is
being used as the trigger. This option is only available when you
are trending in a Triggered mode.

Sample Interval allows you to
specify the sampling interval
when you are real-time trending
from a controller. Drives sample
at the fastest rate possible.

Note If the Trend Recorder is left running in triggered record mode for an extended
period, multiple events can be captured.
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Continuous/Triggered Recording
The default size of this buffer
is 2MB, which corresponds to
approximately 16 minutes of
data when sampling 4 signals
at the fastest sampling rate
(32 ms between samples).

Real-time trends can be recorded continuously or in a triggered mode through the
Real-time Trending Record Mode in the Trend Recorder Settings dialog box,
shown in the section, Configuring the Trend.
Continuous recording collects data until the trace buffer is full. The trace buffer is
an internal buffer used to store data while recording and displaying traces. The size
of the buffer is set using the Trend Recorder Settings dialog box. When the trace
buffer is filled, the Trend Recorder will continue recording, deleting the oldest
values as it adds new ones to the buffer.
Triggered recording collects data based on an external event. In this mode, the
Trend Recorder watches a designated trigger signal. When the value of this signal
satisfies the specified trigger condition, data is collected. The trigger signal must be a
Boolean signal, and the Trend Recorder can be configured to trigger on the signal
being True or on a change of value. Data is collected for a specified time interval
before and after the trigger condition occurs. Once the data is collected, the Trend
Recorder resumes watching the trigger signal for the next event. Each time data is
collected, it is saved as a separate event within the trend file.

Tip ¬ Refer to Chapter 5 for further information on events.
À To set the size of the Trend Recorder Buffer
Increasing the value of this
field also increases the
amount of memory needed to
run the toolbox.

GEH-6408A Trend Recorder

1.

From the Options menu, choose Settings.

2.

Choose the Trend Recorder tab.

3.

Change the value in the Trender Memory Buffer size text box. (Refer to the
section, Trend Recorder Settings.)
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Adding Signals Using Menu
À To add a signal
Or click

Add Signal

w

From the Edit menu, choose Add Signal. The Add Signal To Trender
dialog box displays for you to enter the name of the signal.

Note The first time this function is invoked, the Select Device For Trend Signals
dialog box displays (shown in the section, Change Device). Choose the device from
which to trend the signal.

Add Signal

Click here to
change the device
from which to
select the signal.
Enter the signal name
or click Browse to
search for a signal.

Tip ¬ When trending signals from an Innovation Series controller, if a signal is
selected using the Signal Selector, it can be qualified using appropriate qualifiers as
follows: The character (~), called a tilde, can be placed before Boolean signal to
invert their sense. The character (#) can be placed before signals that are connected
to I/O points to use the Signal Health bit and not the signal itself.

Change Device
List of available devices.
Click on a name and
click OK.

Click an option button
to select from the
devices loaded in the
toolbox or to select
from network devices.
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Adding Signals Using Drag-and-Drop
À To add a signal
The drag-and-drop feature
allows you to trend
automatically named signals
from Innovation Series
controllers and drives.

1.

From the Block Area/Summary View (or Detached Summary View),
click on a pin or a signal name in a block diagram.

2.

Drag the signal (using the mouse) to the top view of the Trend Window and
drop (release the mouse button). The Trend Recorder Channel
Configuration dialog box displays.

When a signal is added to the Trend Recorder from a controller, the toolbox checks
to see if the signal is an internal signal or an external DLAN+ signal. If it is an
internal signal, token (address) information should exist in the device for the signal.
This information is used to trend the signal.
If the signal is an external (DLAN+) signal, the toolbox attempts to find the signal in
the SDB. If it finds the signal, it determines if the signal is available on the DLAN+
that the device is attached to. Then, the signal can be trended.
Note When a signal cannot be added or trending cannot be performed, an
appropriate error message displays. Follow the instructions from the message box to
correct the situation.
Once the signal is added to the trend, the range (upper and lower limits of Y-axis)
and other properties related to the signal can be set in several ways (see the next
section, Editing Properties).

Editing Properties
À To set the signal range and other properties
Click on the signal in the
lower Signal View with the
right mouse and choose
Properties.

1.

From the lower Signal View, click on the desired signal.

2.

From the Edit menu, choose Edit Selected Signal. Or, double-click on the
desired signal from the lower Signal View. The Trend Recorder Channel
Configuration dialog box displays.

Channel Configuration Dialog Box
Allows you to
change the color,
line style, and line
thickness of the
pen used to
outline the trace
for the signal. A
trace is a visible
indication of the
path of a signal.

Sets the upper
and lower limits of
the Y-axis labels
for the signal(s).

Click to display the Signal Scaling dialog box to
provide scaling for either an internal signal in a drive
or an external DLAN+ signal in a controller.
(See the next dialog box, Signal Scaling .)

Note If the line width is greater than one, only solid style is available.

GEH-6408A Trend Recorder
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Signal Scaling

If the signals being trended are internal signals (AcDcEx), the values defined allow
signals to use engineering units instead of raw (count) values. If they are external
signals (controller), these fields are grayed out and the scaling is defined in the
database, and the dialog serves a display-only purpose.

Editing Signals
À To remove a signal from the real-time trend

Or click

1.

From the lower Signal View of the Trend Recorder Window, click on the
signal(s) to be removed. More than one signal can be removed at the same time
by selecting multiple signals in the list.

2.

From the Edit menu, choose Remove Signal.

Remove Signal

À To select which signal’s range is displayed on axis
Click on the desired signal in
the lower Signal View with
the right mouse button.
Choose either Left Axis or
Right Axis (a check mark
displays beside the selected
signal).

1.

From the lower Signal View of the Trend Recorder Window, choose the
signal(s) you want to display on the axis.

2.

From the Edit menu, choose either Show on Left Axis or Show on Right
Axis. A check mark displays beside the selected signal.

– Or –
w

Click on the labels for either the left or right axis. This will cycle through all the
signals that are displayed on the graph.

The position of a signal in the signal list can be changed relative to other signals.
À To change the position of a signal in the signal list
Or use the right mouse button
and click on the desired
signal in the lower Signal
View. From the pop-up menu,
choose Move Up or Move
Down.

1.

From the lower Signal View, choose the signal(s) to be moved.

2.

From the Edit menu, choose either Move Signal Up or Move Signal Down.

Signals in a list can also be hidden. If a signal is hidden, the data for that signal is
still collected, but the signal is not displayed. For example, use this feature if a large
number of signals are collected and only part of the data needs to be displayed.
À To hide signals in the trend
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1.

From the lower Signal View of the Trend Recorder Window, click the
signal(s) you want to hide.

2.

From the Edit menu, choose Hide Signals. (To redisplay hidden signals,
choose Show Signals.)

GEH-6408A Trend Recorder

Block Collected Trends
The Trend Recorder can upload and display data collected by blocks in the controller
or drive. The Innovation Series controller and drive use the Capture block and the
AcDcEx drive uses Circular List blocks (CLST1, CLST2, or CLST3) to collect
data. The Capture and Circular List blocks must first be configured to capture data.
Once the blocks are configured, the Trend Recorder is set up to access data from
these blocks.

Configuring the Trend
À To set up the block-collected trend
1.

From the Edit menu, choose Configure. The Trend Recorder
Configuration dialog box displays.

2.

From the Trend Type option buttons, choose Block Collected. If you have
more than one controller or drive open in the toolbox, you will be prompted to
select one.

The dialog box changes to the Block Collected Trend Configuration.

Block Collected Trend Configuration
Select the Block Collected tab to
specify a trend based on
uploaded data from the drive or
controller.

Save Mode allows you to specify whether to save
just the setup for the trend or save the setup and
all data that is collected. Setup Only saves all the
signals, their scaling, the sample interval, axis
ranges, and other setup data.

A Capture Buffer is
specified by the
name of the signal
that is attached to
the status output pin
of the block (and is
only used if the
Trend Recorder is
attached to a
controller).
Click the Browse
button to choose
which block to
upload data from.
If the Trend
Recorder is
attached to a drive,
the Capture Buffer
text box and Browse
button are disabled.
Enables automatic upload of data from the block. In this mode,
the toolbox watches the status of the block collector and
initiates an upload every time the block finishes collecting.

GEH-6408A Trend Recorder
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Note There can be more than one Capture Buffer block in a controller. There can
only be one Circular List block in an AcDcEx device and only one Capture Buffer
block in an Innovation Series drive.
The toolbox automatically configures the Trend Recorder to use the signals on the
collector block (Capture Buffer or Circular List) configuration in the current device.
Signals cannot be added or removed from a block-collected trend; the configuration
of the block must be changed. All other operations on signals defined for real-time
trending can be performed.
À To modify the block configuration
Or click

Edit Block

1.

From the Edit menu, choose Edit Block.

2.

Modify the block as desired.

Tip ¬ (Refer to Chapter 4 of the relevant device manual for editing blocks.)

Uploading Data
À To view data from the collector block
Or click

Upload

w

From the View menu, choose Upload Data.
If the trend is configured to automatically upload collected data, the toolbox
monitors the status signal of the collector block and initiates an upload every
time the block finishes a collection. While in this mode, the Automatic
Collector Block Upload dialog displays:

Upload Data

Click Stop to stop
automatic upload.
The last event uploaded
displays on the graph.

Note If the trend is configured for manual upload of captured data, a one-time
upload will be initiated when the Upload button is selected. When the upload is
complete, the data displays on the graph.
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Data Historian Trends
The Trend Recorder can upload and display data collected by the Data Historian.
The Data Historian is a service on a Windows NT platform. It can collect data
continuously or upload Capture Buffers from a controller. The Data Historian
configuration groups signals into collections. There are two types of collections:
real-time continuous or Capture Buffer uploaded. Collected data for each
collection is stored in .dca format files.

Configuring the Trend
À To set up a Data Historian trend
1.

From the Edit menu, choose Configure. The Trend Recorder
Configuration dialog box displays.

2.

From the Trend Type option buttons, choose Data Historian. The Data
Historian Trend Configuration dialog box displays.

Data Historian Trend Configuration
Select the Data Historian tab to
specify a trend based on data
collected by the Data Historian.

Save Mode allows you to specify whether to save
just the setup for the trend or save the setup and all
data that is collected. Setup Only saves all the
signals, their scaling, the sample interval, axis
ranges, and other setup data.

Enter the Microsoft
Networking name for
the PC that is the
host for the Data
Historian service.

Select the mode of
the X-Y plot. For a
detailed description
of X-Y plots, refer to
the section, X-Y
Plots, in Chapter 5,
Viewing Trends.

Click OK, and add signals to the Data Historian collection. (Refer to the section,
Adding Signals.)

GEH-6408A Trend Recorder

Chapter 3 Types of Trends • 17

Adding Signals
À To add signals to the Data Historian trend
Or click

Add Signal

w

From the Edit menu, choose Add Signal. The Data Historian Signal
Selection dialog box displays the following two choices for choosing signals.

Pick from Signal List
displays signals using
the normal Signal
Selector dialog box.

Pick from Collection
List displays a list of
signals from a
specified collection.
First, choose a
collection. Then,
choose a signal.

Choosing Signals From a Collection

Choose a signal from
the collection. Multiple
signals can be chosen
from this list.

If signals are added to the trend from more than one device, the lower Signal View
displays the name of the device before the name of the signal as follows:

After all the signals are added, the trend recorder reads data from the Data Historian
host and graphs the data (refer to the section, Recording Trends, in Chapter 4).
Signal settings can be edited the same as for real-time trends.
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.dca File Trends
The Trend Recorder can read data from data collection analysis (.dca) files. These
files provide a standard format for storing data. The files can be written by many
different software applications.

Configuring the Trend
À To set up a .dca file trend
1.

From the Edit menu, choose Configure. The Trend Recorder
Configuration dialog box displays.

2.

From the Trend Type option buttons, choose DCA Files. The .dca File-Based
Trend Configuration dialog box displays.

.dca File Trend Configuration
Select the DCA File tab to
specify a trend based on data
stored in DCA files.

Save Mode allows you to specify whether to save
just the setup for the trend or save the setup and
all data that is collected. Setup Only saves all the
signals, their scaling, the sample interval, axis
ranges, and other setup data.

Click here to add a
.dca file to the trend.
Type the name of the
file in the DCA File
dialog text box, or use
the drop-down list to
choose a file.
Click here to remove
files from the trend.

To view the trends, refer to
Chapter 5, Viewing Trends.

GEH-6408A Trend Recorder

Click OK. The file list is read and a trend is generated from the data contained in the
files. (See the section, Recording Trends, in Chapter 4.)
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Chapter 4 Using the Trend Recorder

Introduction
The following sections describe how to record, save, export, and print a trend. Once
recorded, the displayed trend can be viewed on the screen just as it would be printed,
or you can choose to print a hard copy.

Recording Trends
After you have added the signals to the trend, you must record the data to view the
trend on the graph.
À To record the trend
Or click

Record

Auto Range
Or click
Vertical Axis

w

From the View Menu, choose Record.

When you want to stop recording, choose Record again from the View menu, or
click the Record button again.
If the data cannot be viewed within the range you selected, you can either modify the
range using the Channel Configuration dialog box (refer to the section, Editing
Properties), or by choosing Auto Range Vert. Axis from the Edit menu.

Saving Trends
Trends can be saved to files for later replay and analysis. The files have the
extension .trn. If the trend is attached to a device when saved, the trend defaults to
the Trends sub-directory, under the directory of the device being trended. If the trend
is not attached to a device, such as a Data Historian collected or .dca file trend, the
trend defaults to the current working directory.
If you want to save just the setup that was recorded, this option must be chosen in the
Trend Recorder Configuration dialog box under Save Mode. (See the section,
Configuring the Trend.) The default for the Save Mode is Setup and Data. If you
save the setup and data, each data event is saved to files of the same name with
extensions starting at .000 and increasing.
À To save the trend
1.

From the Edit menu, choose Configure.

2.

From the Trend Recorder Configuration dialog box, choose the desired
Save Mode and click OK.

3.

From the File menu, choose Save or Save As.

À To open a previously saved trend
w

GEH-6408A Trend Recorder

From the File menu, choose Open. Choose the device directory and then the
Trends sub-directory. Use the filename with the .trn extension.
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Exporting Trends to .csv Files
Trends can be exported to a comma separated variable (.csv) file. Then, this text file
can be imported by spreadsheets, such as Microsoft Excel or other applications.
À To export a trend
The default options are
standard .csv format and
should only be changed if you
have special format
requirements.

1.

Open the trend you want to export in the Trend Recorder.

2.

From the File menu, choose Export Trend Data. The Trender Export Data
Options dialog box displays.

3.

Choose a new format for the output file, if needed. (Refer to the next section,
Trender Export Data Options.)

4.

Enter a filename for the .csv file.

Trender Export Data Options
Check to make the first
line of the file contain
the name of each signal
in the trend.

Change the delimiting
character to something
other than the default,
which is a comma.

Check to make the first
column of the exported
file contain the date and
time for each sample
set of exported data.

Set the text that will be
written to the file when
there is no value for a
particular signal in a
given sample set. The
default is a blank space.

Check to make the first
column of exported data
a sample sequence
number.
Check to export just the
data between the two
replay cursors in the
current trend event.

Printing Trends
The currently displayed trend can be printed or print previewed.
À To print a trend
w

From the File menu, choose Print (to produce a hard copy).

− Or −
w

From the File menu, choose Print Preview (to view the trend on the screen as
it would be printed).
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Chapter 5 Viewing Trends

Introduction
An event is a set of data
recorded without
interruption.

GEH-6408A Trend Recorder

When the Trend Recorder is not recording or uploading data, it is in replay mode. In
replay mode there can be multiple events stored in the trend.
•

For real-time continuous recording, there is an event each time the Record
mode is chosen.

•

For real-time triggered recording, there is an event each time the trigger
condition is satisfied.

•

For block-collected recording, there is an event for every upload that occurs.

•

In Data Historian and .dca file trends, all data is maintained in a single
continuous event (only one event).
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Moving Between Events
À To access other events
Or choose the View menu for
a list of all view commands.

w

From the toolbar, click

to view the next event.

− Or −
w

From the toolbar, click

to view the previously displayed event.

Note When you move between events, the Status bar shows which event is
currently displayed.
À To move backward or forward within an event
Or choose Rewind or
Forward from the View menu.

w

From the toolbar, click
or
. These buttons move back or forward
within the current event by one-third of the currently displayed width of the time
axis.

Changing The Time Axis
The range of the time axis can be changed by using the Trender Time Axis dialog
box, or see the section, Zoom In/Zoom Out.
À To edit the time axis
w

From the Edit menu, choose Time Axis. The Trender Time Axis dialog box
displays. This dialog box varies depending on the type of trend.

Real-time and block-collected trends require a single range in seconds.
Data Historian and .dca file trends allow you to set Start and End dates and times.
(Refer to the section, Data Historian/.dca Time Axis.)

Trender Time Axis
Real-Time/Block-Collected Trends
Real-time and
block-collected trends
require a single range
in seconds for the time
axis.
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Data Historian/.dca File-based Trends

Data Historian and
.dca file-based trends
allow you to set Start
and End dates and
times for the time axis.

Using the Replay Cursors
Replay mode has two moveable cursors: a left cursor and a right cursor. The active
cursor displays white and can be moved using the mouse or arrow keys on the
keyboard.
Active cursor

Cursor

À To move a cursor using the mouse
1.

Place the mouse pointer at the top of the cursor and click. The cursor turns white
to indicate it is active.

2.

With the mouse pointer at the top of the cursor, press and hold the left mouse
button and drag the cursor right or left to the desired position.

À To move a cursor using the arrow keys
To move the cursor faster,
press and hold the Shift key
as you press the arrow key.
If the cursor is placed exactly
on one sample, the value will
have an asterisk beside it.

1.

The active cursor is white. Press the Tab key to toggle the active state of the
cursors, and select the desired cursor.

2.

Press and hold the right or left arrow key to move the cursor to the desired
position.

As the cursor is moved, its values are displayed on the Status bar as follows:
•

Left value is the value of the left cursor

•

Middle value is the value of the right cursor

•

Right value displays the difference between the two cursors

Note The Status bar also indicates the time of each of the cursors and the difference
between the times.
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Zoom In/ Zoom Out
When the Trend Recorder is in Replay mode, you can zoom in and zoom out of the
trend.
À To zoom in on the trend
Or click

Zoom In

w

From the View menu, choose Zoom In. The view of the trend zooms in to the
area between the cursors. The cursors are repositioned to be at the left and right
edges of the displayed area. The range of the vertical axis does not change.

− Or −
Place the mouse pointer at the top left corner of the area to you want to zoom in.
Click and hold the left mouse button, then drag the pointer to the bottom right corner
of the area.
À To zoom out of the trend
Or click

Zoom Out

w

From the View menu, choose Zoom Out. The view of the trend zooms out to
three times the width and height currently being displayed. Zoom Out stops
when the width and height reach their original values.

− Or −
Place the mouse pointer at the bottom right corner of the area to you want to zoom
out. Click and hold the left mouse button, then drag the pointer to the top left corner
of the area.

Stacked Signal Traces
A trace is a visible path of a
signal.

In the default view for displaying graphs, all traces are on one common graph
(shown below). To view each trace separately, place the Trend Recorder in stacked
view as follows:

Traces

The order of
signals in
stacked mode
matches the
order in the
lower Signal
View of the
Trend Recorder
window.
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À To view Stacked Traces
To return to normal view,
choose Stacked Traces again.

w

From the View menu, choose Stacked Traces. A check mark (ä) displays
beside the command when in stacked mode.
The order of signals in stacked mode matches the order in the lower Signal
View of the Trend Recorder window.

If there are too many traces in one graph to display every signal in stacked view, the
Trend Recorder automatically returns to normal view. To adjust the number of signal
traces in a view:
Click
screen.

to maximize

•

Maximize the size of the screen.

•

Or, remove signal(s) from the list in the lower Signal View. (From the Edit
menu, choose Remove Signal.)

•

Or, choose a smaller screen font size. (From the Options menu, choose
Settings, then choose the tab Trending.)

À To change the position of a signal in a stacked trace
1.

From the lower Signal View, click on the signal(s) to move.

2.

From the Edit menu, choose either Move Signal Up or Move Signal Down.

– Or –
1.

Click on the desired signal with the right mouse button.

2.

From the pop-up menu, choose Move Up or Move Down.

Auto-Ranging the Displayed Data
The auto-range function examines the range of values for each signal in the time
range currently displayed on the Trend Recorder. The range of each signal is then
adjusted to display the graph using as much of the display area as possible.
Or click
Auto Range
Vertical Axis

À To auto-range the displayed data
w

From the Edit menu, choose Auto Range Vert. Axis.

X-Y Plots
The Trend Recorder can convert plots of data that have been recorded in real time
and re-plot the data where one (or more) of the variables in the trended set is
designated as the X-axis. X-Y plots are normally created using the data between the
replay cursors.
There are two modes of X-Y plots: Between Cursors, which is the normal mode, and
At Left Cursor.
Between Cursor mode plots the values that are between the two cursors against the
designated X-axis. This mode of X-Y plots is available for all types of trends.
At Left Cursor mode is available only for Data Historian collected trends. In this
mode, the X-Y plot is generated using the entire data set in the individual .dca data
file(s) that contain the sample time currently at the left cursor. This would typically
be used to do an X-Y plot of all the data for an individual unit of a batch
manufacturing operation, where data for each unit in the batch is collected in its own
.dca file.
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The value increases or
decreases, but not both.

The signal used as the X-axis must have a monotonically changing value over the
time span that data is to be plotted.
À To create an X-Y Plot using a single X-axis signal

Or click

X-Y Plot Mode

1.

Obtain a plot of data using any of the methods of collecting data.

2.

Choose one of the signals to be the X-axis. Click on the signal in the lower
Signal View of the Trend Recorder.

3.

From the Edit menu, choose Set As X Axis.

4.

Position the replay cursors to the start and end times of the data to plot in X-Y
mode.

5.

From the View menu, choose X-Y Plot Mode.

6.

Repeat step 5 to return to time-based mode.

À To generate an X-Y Plot using multiple X-axis signals
Plots using multiple signals for the X-axis can be used when there is a Data Historian
collected trend and that trend contains data from multiple collections. One signal
from each collection can be specified as an X-axis. All the other signals from that
collection are plotted against the values of that signal.

Or click

X-Y Plot Mode

1.

Obtain a plot of data using any of the methods of collecting data.

2.

Choose the signals to use for the X-axis. Click on multiple signals (Shift/click
and Ctrl/click) in the lower Signal View of the Trend Recorder.

3.

Position the replay cursors to the start and end times of the data to plot in X-Y
mode.

4.

From the View menu, choose X-Y Plot Mode.

5.

Repeat step 4 to return to time-based mode.

À To generate an X-Y plot using all the data from .dca files
An X-Y plot for all the data can also be obtained in an individual event file. This
function works only with Data Historian collected trends and is most commonly used
with Capture Buffer collections.

Or click

X-Y Plot Mode
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1.

From the Edit menu, choose Configure.

2.

From the X-Y Plot Mode options, choose At Left Cursor.

3.

Obtain a plot of data in time-based mode using any of the methods of collecting
data.

4.

Choose the signals to use for the X-axis. Click on multiple signals (Shift/click
and Ctrl/click) in the lower Signal View of the Trend Recorder.

5.

Position the left cursor somewhere in the middle of the data event that you wish
to plot in X-Y mode.

6.

From the View menu, choose X-Y Plot Mode.

7.

Repeat step 6 to return to time-based mode.
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Power Spectrum
The Trend Recorder can perform a spectral analysis on plots of real-time data and
display the power spectrum of the recorded data. The Trend Recorder uses a Fast
Fourier Transform (FFT) to convert the data from the time domain to the frequency
domain. Power spectrum plots may be obtained from any trend but are most reliable
with data obtained using a block-collected trend. Power spectra of data collected
using real-time trending, especially of data coming across networks, should be
regarded as unreliable.
À To create a Power Spectrum plot
1.

Obtain a plot of data using any of the types of collecting data.
Best results will be obtained when data is collected using block-collected trends
with the capture block configured to collect a number of samples that is a power
of 2 (512, 1024, 2048, etc.). The more samples collected, the better the
resolution of the power spectrum.

2.

From the View menu, choose Power Spectrum.

The FFT Options dialog box displays.

FFT Options
Select the window function to
use with the data. (Refer to the
note below.)
Select how many additional
powers of 2 the data is padded
with 0 values.
The Fast Fourier Transform
algorithm requires a data set
where the number of samples
is a power of 2. Increasing the
padding beyond the nearest
power of 2 increases the
apparent resolution of the
power spectrum.

Check for the power
spectra analysis to be
performed on the data
between the two cursors,
instead of on the entire
set of data contained in
the current event being
trended.
Check to remove any
DC component of the
power spectrum that
could distort the
appearance of the
spectrum near 0 Hz.

Note A variety of windowing functions (such as Hanning, Hamming, Bartlet,
Welch, and others) are available to minimize phenomena associated with the discrete
time-window nature of the collected data. Refer to other signal processing theory
textbooks for explanations of the theory of operation of Fast Fourier Transforms,
such as Introduction to Communication Systems, Ferrel G. Stremler; Electrical
Noise, W. R. Bennett; Circuits and Systems: A Modern Approach, A. Papoulis.
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Glossary of Terms

AcDcEx
Refers to ac drives (AC2000), dc drives (DC2000), and exciters (EX2000) devices,
which are all referenced in the combined device type name. These three devices can
use the same application control boards and devices in the toolbox.

automatically named signals
Signals that are created as a result of inserting some item of blockware other than a
Signal Definition. One or more regions of such signals is of the form }00123.

bit
Binary Digit. The smallest unit of memory. It can be used to store only one piece of
information that has two states, such as One/Zero, On/Off, Good/Bad, or Yes/No.
Data that requires more than two states, such as numerical values of 000 to 999,
requires multiple bits (see Word).

block
A unit of information that is processed or transferred. These elemental units exist in
the runtime. The toolbox receives a description of the blocks from the block libraries.

blockware
Software that is composed of blocks. (See block.)

board
Printed wiring board.

Boolean
Digital statement that expresses a condition that is either True or False. In the
toolbox, it is a data type for logical signals.
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configure
To select specific options, either by setting the location of hardware jumpers or
loading software parameters into memory.

device
A configurable element of a process control system.

DLAN+
GE Industrial Control Systems’ LAN protocol, using an ARCNET controller chip
with modified ARCNET drivers. A communications link between exciters, drives,
and controllers, featuring a maximum of 255 drops with transmissions at 2.5MBps.

event
A property of Status_S signals that causes a task to execute when the value of the
signal changes.

font
One complete collection of letters, punctuation marks, numbers, and special
characters with a consistent and identifiable typeface, weight, posture, and size.

function
The highest level of the blockware hierarchy and the entity that corresponds to a
single tree file.

health
A term that defines whether a signal is functioning as expected.

I/O
Input/output. Interfaces that allow the flow of data into and out of a device.

insert
Adding an item either below or next to another item in a configuration, as it is
viewed in the Outline View of the toolbox.

logical
Statement of a true sense, such as a Boolean.

pin
Block, macro, or module parameters that creates a signal used to make
interconnections.
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real time
Immediate response. It refers to process control and embedded systems, and fast
transaction processing systems that must respond instantly to changing conditions.

sample set
The set of values taken when signals are being trended together with the Trend
Recorder.

sampling rate
The period that values are collected to put in a sample set.

service
Functionality derived from a particular software program. For example, the Data
Historian service transmits and provides conversion of data in the SDB.

signal
The basic unit for variable information. Signals are the place holders for memory
locations in the toolbox’s different platforms.

Status_S
GE proprietary communications protocol that provides a way of commanding and
presenting the necessary control, configuration, and feedback data for a device. The
protocol over DLAN+ is Status_S. It can send directed, group, or broadcast.

task
Part of a Module that contains Blocks and Macros. Its scheduling is a function of its
Modules base scheduling rate.

toolbox
A Windows-based software package used to configure controllers and OC2000 and
drive devices.

trend
A time-based plot to show the history of values.

Trend Recorder
A subsystem of the toolbox that monitors and graphs signal values from a controller
or drive device.
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Windows NT
Windows New Technology. Advanced 32-bit operating system from Microsoft for
386s and above. It runs NT-specific applications, as well as those written for DOS,
Windows 3.x (16- and 32-bit), OS/2 character mode (non-graphical), and POSIX.
NT does not use DOS; it is a self-contained operating system.
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