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Chapter 1
Introduction
UPSentry Manager provides the most useful information about power status of the UPSs in the
network. It is an easy-to-use program that furnishes you with a complete set of utilities to
configure and monitor system performance so as to obtain maximum results. Its ability to remote
monitor and control lots of UPSs is only one of the superb features.

UPSentry Manager Features:
l
l
l
l
l
l

Remote monitoring and control UPSs through TCP/IP network
Monitoring and control UPSs through serial communication port
Collect information of all of the UPSs into one program
Provide hierarchical architechure to manage all of your UPSs
Provide audible alarm, broadcasting, paging and e-mail during unstable power
condition
Monitor and display voltage, frequency, current and loading etc.

1-1

Chapter 2
Overview
UPSentry Manager is an omnibus UPS management system. It can not only connect your UPSs
through network but also has the ability to manage your UPSs through serial port.
It provides a standard graphic interface so that users can easily manage UPSs and share a
common alarm system.

Networking:
There are several ways to manage UPSs through network by UPSentry Manager:
1. UPSentry Smart 2000
2. 3Phase UPSentry
3. SNMP card
Serial Port:
Users can use RS232-to-RS485 adapters to cascade UPSs in one serial port or insert a
multi-port card in the PC to connect UPSs in these serial ports.
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Chapter 3
Creating UPS Maps
The following example uses UPSentry Manager to create a simple UPS map. The map file
containing the submaps is SouthUPS.UMF. SouthUPS consists of a home map, three regional
submaps, and three local submaps for each regional submap.
Table of SouthUPS Submaps
Home
Submap

Regional
Submaps

Local
Submaps

Devices

Europe

London

Lab #11,12

Berlin
Vienna
Osaka
Tokyo

Sales #4
Sales #8
Sales #25,27
Sales #28,29,30

New York
Houston
Los Angeles

Marketing #51,52
Lab #101,102
Sales #83

World

Japan
USA

To create a map file, follow these steps:
1. Choose New from the File menu to create a new map.
UPSentry Manager will display an empty map with a name: Main.
2. Choose Save As from the File menu to name the map file PRACTICE.
Adding a Background
It’s not necessary to use a background for a submap. They are independent of your UPS
map data and can be added at any time. However, if you have access to suitable .BMP
images, they can actually make it easier to position icons.
1. Choose Background from Object menu.
2. Press Browse button, choose World.bmp then press OK.
Adding Group Symbols
To add group symbols to your map, follow these steps:
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1. Choose Add Group from Object menu to display the Property dialog box.
2. Name the group title.
3. Click on OK.
Adding UPS Symbols
To add UPS symbols to your map, follow these steps:
1. Choose Add UPS from Object menu to display the Property dialog box.
2. Name the UPS title, fill the IP address and port number.
3. Click on OK and Connect.
Adding SNMP UPS Symbols
To add SNMP Site symbols to your map, follow these steps:
1. Choose Add SNMP Site from Object menu to display the Property dialog box.
2. Name the UPS title, fill the IP address and community string.
3. Click on OK and Connect.
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Chapter 4
File Menu
This chapter introduces you to handle UPSentry Manager file and how to load a file at startup.

New
Allows you to create a new file. If the previous file has been changed it will pop up a dialog
box to ask you to save the previous file.

Open
Open a previous saved file.

Save
Save current layout and settings.

Save As
Save to other file name.

Load At Startup
This menu allows you to load the assigned file when the program startup.

Exit
Stop the program.
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Chapter 5
Object Menu
Property
Display the selected object property dialog box. Allow you to modify the object property
values.

Background
This menu enables you to configure the background bitmap. UPSentry Manager only
supports bitmap format file.

Move
To move between objects, move into the selected group or move back to the upper level.
Move Up: Press Up Arrow or PageUp on the keyboard.
Main
Group 1-1

Group 1-1-1

UPS 1-2

Group 1-1-2

Group 1-3

Current Level

Group 1-3-1

Move Into: Press Down Arrow, PageDown on the keyboard or double-click the
left-button on you mouse.

Main
Group 1-1

Group 1-1-1

UPS 1-2

Group 1-1-2

Group 1-3

Group 1-3-1
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Current Level

Move Next: Press Right Arrow on the keyboard.

Main
Group 1-1

Group 1-1-1

UPS 1-2

Group 1-1-2

Group 1-3

Current Level

Group 1-3-1

Move Previous : Press Left Arrow on the keyboard.

Main
Group 1-1

Group 1-1-1

UPS 1-2

Group 1-1-2

Group 1-3

Current Level

Group 1-3-1

Cut
Cut the selected object to the clipboard. You should paste it to different layer.

Paste
Paste the object which cut previously. The commands of "Cut", "Paste" are designed to
move the objects to reflect the object in real world.

Delete
This menu lets you to delete the selected object.

Delete All
This menu lets you to delete all of the objects.

Add Group
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This menu lets you add a Group object in the current level. As you select this menu
UPSentry Manager will pop up a Property dialog box to let you name the Group title.

Add UPS
Add an UPS object in current layer. You can choose 2 different methods to connect to
UPS:
Networking
this option is used to connect UPS through UPS software. If you want to connect to
3Phase UPSentry then you must assign the same network port, if you want to connect to
UPSentry smart 2000 just leave the network port as 0.
Local
You must assign a communication port which the UPS connects to. If the UPS is cascade
by RS485 then you must assign the UPS ID.

Add SNMP UPS
Add a SNMP object in current layer. As you select this menu UPSentry Manager will pop
up a Property dialog box to let you name the SNMP title, assign the UPS IP address and
community string. UPSentry Manager supports only UPS SNMP. You can use this
function to monitor and control our UPS SNMP devices.

MIB Browser
Please find the SNMP MIB from the SNMP device user's manual. MIB Browser gets
values by group each time.
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Chapter 6
Manage Menu
Connection
Period Time to Establish Connection: UPSentry Manager tries to establish connection to
those disconnect networking UPSs in a period of time.
SNMP Polling Interval: Adjust this value to reduce the SNMP packages in the network.

Modem
UPSentry Manager supports Hayes AT commands To acquire an outside line from a PBX
system, you may have to dial 0 or any other specified number to obtain a dial tone. The dial
prefix is ATDT0W.
When you select the Using TAPI check box, UPSentry Manager calls the telephony API to
handle the selected device. UPSentry Manager ignores the communication port, baud rate,
initialize string and dial prefix string. You can set your modem parameters from the control
panel.

Pager
Allows you to sent out paging information when certain events occur.
If your paging number is 1234567 , , , , #995#, this number is represented as follows:
Pager number - 1234567
The number of the pager you want to call.
Comma delay - , , , ,
The time (in seconds) needed for the paging service to answer and gets ready to accept the
paging message. The 4 commas represent 8 seconds. Additional commas mean additional
seconds.
Paging message - 995
The message or information sent is represented by numbers.
To add, modify or delete the paging number, click on its respective command button.

Broadcast
If you want to broadcast the message in NT domain, please select Domain check box.
Otherwise UPSentry Manager sends the messages to the assigned hosts.

e-mail
There are 2 ways to send e-mail.
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MAPI:
To send e-mail by MAPI, UPSentry Manager needs to run with MS Outlook. The name in
the Name list should also exists in the Microsoft Exchange address book.
SMTP:
Send e0mail by SMTP through network port 21.

Action
The action menu provides you with a list of events to choose from. The event and/or any
combination of these actions can be selected from the Choose Event list box. Actions that
are already enabled will show a right mark.
Log
Permits you to log-in event as well as modify default logging message. To enable
or disable this action, mark the Enable Logging check box.
Broadcast
Permits you to broadcast an event based on a set period of time. If you want to
be notified once, set the time period to “0”. However, if you want to be notified
more than once, set the time period to a bigger number. Each number
corresponds to the times of notification.
Modification of default broadcasting message or event is possible by changing the
text in the Broadcast Message directly. To enable or disable this action, mark the
Enable Broadcasting check box.
Pager
Permits you to set the time period of paging intervals. If you want to be notified
once, set the time period to “0”. However, if you want to be notified more than
once, set the time period to a bigger number. Each number corresponds to the
times of notification.
You can edit the page list by clicking on the Edit list button, and add, modify or
delete any paging data in the list. To test this function, you can click on the Test
button. To enable or disable this action, mark the Enable Paging check box.
Command
Permits you to execute command files and set a period of time to delay its
activation. To test this function, you can click on the Test button. To enable or
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disable this action, mark the Enable Command check box.
Alarm
Permits you to send out audible alarm instead of a broadcast message. There are
two alarms to select from - Buzzer and Audio. If you choose Audio, the
UPSentry-pro Unit require a “.wav” file to emit the alarm. You can browse your
system for other “.wav” file by clicking on the Browse button.
If you want to be notified once, set the time period to “0”. However, if you want
to be notified more than once, set the time period to a bigger number. Each
number corresponds to the times of notification.
To test this function, you can click on the Test button. To enable or disable this
action, mark the Enable Alarm check box.
e-mail
Permits you to send mail through Microsoft Exchange. If you want to be notified
once, set the time period to “0”. However if you want to be notified more than
once, set the time period to a bigger number. Each number corresponds to the
times of notification.
You can edit the page list by clicking on the Edit list button, and add, modify or
delete any paging data in the list. For testing this function, you can click on the
Test button. To enable or disable this action, mark the Enable e-mail check
box.

All Alarms
This menu offers you the possibility of viewing past events of all objects. To print the event
log, click on the Print command button. Press Clear All button will clear all of the alarms.
Maximun alarm entries: It allows you to store up to a maximum of 1,000 entries (1-1,000)
by keying in the number of entries you wish to store.
Alarm Events: The event assigned the alarm level can be selected from the Alarm Event list
box.
Default: Set the default value.
Manage
Press the Manage button will pop up a dialog box to manage the warning level of
all the alarm events. There are 3 levels: Information, Warning and Severity, you can
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change their color from Color menu.
This menu lets you store and set data for viewing the Alarm.
Maximun alarm entries:
It allows you to store up to a maximum of 10,000 entries (1-10,000) by keying in
the number of entries you wish to store.
Alarm Events:
The event assigned the alarm level can be selected from the Alarm Event list box.
Default:
Set the default value.

Selected UPS Alarm
This menu shows the same as All Alarm menu except the alarm events are all of the
selected UPS.

Color
This menu provides you with the possibility of changing the colors of key items on the
main screen to suit your viewing comfort.
To change, highlight the color item and click on Change. Pick the desired color on the
color dialog box and exit to confirm the change. To set the color back to its original
setting, click on the Default button.

Control Items for Serial UPS
This menu lets you send commands to a selected UPS, UPSs in a layer or all of the UPSs.
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